Saitek Multi Panel not working right!

classic Classic list List threaded Threaded
15 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Saitek Multi Panel not working right!

joe33024
Has anyone experienced problems with Saitek Multi Panel not working properly. In my case the selection knob does not interface with FSX, meaning that if you select HDG rotating left from ALT the AP panel in FSX does not reflect the new position or function. Also the rotary knob used to change direction altitude or what ever only advances; so if I turn to the right from 89 I get 90 but if I turn to the left from 90 I get 91 not 89. WHAT? Do registered installs of FSUIPC 4.80 or WideFS 6.94 have anything to do with this problem? Do I have to configure SPAD in any special way?

In the SPAD screen then rotary knob also reflects the same behavior although the selection knob indicates and functions properly.

Any Ideas?
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Saitek Multi Panel not working right!

maxx
Administrator
Hi Joe,
first of all.
Which aircraft are you using ?
Are you using the default SPAD setup ?

And no, registered FSUIPC and WideFS should be fine.

Ciao,
Massimo
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: Saitek Multi Panel not working right!

joe33024
Thank you for your prompt replay!

Aircraft - Standard out of the box Cessna 172 no whistles or bells

Just installed SPAD and left it alone; other than trying to troubleshoot
problem with the config screen!
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: Saitek Multi Panel not working right!

maxx
Administrator
You're lucky... I was reading the forum

So we are talking about the default C172 which should work out of the box.

When you switch the selector knob nothing should happen in the simulator.
The real thing doesn't have a selector knob.
If you change the HDG on the panel you should see the movement here:


So, to be sure that anything is setup correctly: quit SPAD, delete every .ini files from the folder where you have installed SPAD, restart SPAD and try again.

Start a fly with the default C172, select HDG on the selector knob and watch the display (on the panel) and the gyrocompass (on FSX).

Are they indicating the same direction ?
Let me know.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: Saitek Multi Panel not working right!

joe33024
You are 100% correct but when I turn the rotary knob the value only increases even if I turn the knob counterclockwise; and this holds true for all functions not just HDG.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: Saitek Multi Panel not working right!

maxx
Administrator
Ok.

On SPAD user interface you should see a drawing of your panel like this:


Does the rotary knob move correctly in the user interface ?
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: Saitek Multi Panel not working right!

joe33024
The Rotary knob on the right above the setup button only increases values on the physical panel itself, FSX and the SPAD user interface. To be clear the rotary knob only turns clockwise on the SPAD user interface.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: Saitek Multi Panel not working right!

maxx
Administrator
Ok, so we have a response.

It's a hardware problem.

What happens with original drivers ??
By the way, have you removed the original drivers before trying SPAD ??
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: Saitek Multi Panel not working right!

maxx
Administrator
Don't consider the numbers.
Look at the red line on the user interface:


Does it move correctly on the user interface or does it rotate only clockwise ?
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: Saitek Multi Panel not working right!

joe33024
It only rotates clockwise.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: Saitek Multi Panel not working right!

maxx
Administrator
ok, and have you removed the original drivers  before  starting spad ?
Does the panel work correctly with the original Saitek drivers ?
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: Saitek Multi Panel not working right!

joe33024
To make sure let install on another system to see if i get the same results! Stand by.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: Saitek Multi Panel not working right!

joe33024
The panel behaves the same way on another system with just FSX and the SAITEK drivers, so I guess I need to have a conversation with them to have the unit exchanged. Thank you for your support, I'll post once I get a replacement unit and try again.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: Saitek Multi Panel not working right!

mwalsh
Did you ever get this resolved?  I'm just starting to have the same problem too.

Mark Walsh
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: Saitek Multi Panel not working right!

Jan Vaane
Loading...